Service Degradation for AVT cards Data, Voice, and SMS service (2G/3G/4G)

Incident Report for Teal Communications

Resolved

The traffic trend has been normalized, and networks are back to normal.
Posted Apr 07, 2026 - 16:06 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 07, 2026 - 16:04 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 07, 2026 - 16:04 UTC

Investigating

We would like to inform that, Our upstream provider has observed a sudden increase in traffic for AVT profile cards, which is causing intermittent network registration failures for customers. Their technical team is actively investigating the potential cause and working on implementing the necessary resolution.
Impact: Data, Voice, and SMS services (2G/3G/4G) may be intermittently affected.
We will keep you updated on further progress. We apologize for the inconvenience caused and appreciate your patience.
Posted Apr 07, 2026 - 15:41 UTC
This incident affected: Network Connectivity.