Service Degradation –Canada Rogers Native Profiles (Quebec, Canada)

Incident Report for Teal Communications

Resolved

This incident has been resolved.
Posted Jul 30, 2026 - 15:10 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 30, 2026 - 15:04 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Jul 30, 2026 - 15:04 UTC

Investigating

We are currently experiencing a service degradation affecting devices on Rogers native profiles. Our upstream IMSI provider (Rogers) has reported an unplanned wireless outage impacting 3G, LTE, and 5G services in the Saint-Jérôme, Lachute, and Sainte-Sophie areas (north of Montreal, QC), ongoing since July 29, 2026, 12:00 PM EDT.
Customers with devices in the affected region may experience degraded or interrupted connectivity on Rogers native profiles. No ETA has been provided yet.
We will post a further update once the issue has been restored.
Our technical teams are actively working with the connectivity partner to restore service.
Posted Jul 29, 2026 - 22:42 UTC