Verizon Native Profile Downloads May Fail

Incident Report for Teal Communications

Resolved

We are pleased to inform you that the issue affecting Verizon Native Profile downloads has been resolved.
Thank you for your patience.
Posted Sep 25, 2025 - 20:34 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 25, 2025 - 20:27 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Sep 25, 2025 - 20:26 UTC

Investigating

We are currently investigating an issue where some Verizon Native Profile downloads may fail. Thank you for your patience as we work with our upstream provider for a solution.

If you have any questions or concerns, please feel free to contact our support team at support@tealcommunications.com.
Posted Sep 25, 2025 - 15:51 UTC
This incident affected: eSIM Operations (eSIM Server #3 (Main)).