Aurora Portal – Limited Availability

Incident Report for Teal Communications

Resolved

This incident has been resolved.
Posted May 26, 2026 - 13:33 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 26, 2026 - 13:33 UTC

Investigating

We are currently observing intermittent availability issues within the Aurora Portal. Users may experience time outs or incomplete page loads at this time.
Our technical teams are actively investigating the root cause and working to restore normal service as quickly as possible.
We appreciate your patience and understanding.
Posted May 26, 2026 - 12:34 UTC
This incident affected: Customer Portal.