Intermittent Plan Change Delay

Incident Report for Teal Communications

Resolved

This incident has been resolved.
Posted Feb 06, 2026 - 17:33 UTC

Update

We are continuing to investigate this issue.
Posted Feb 03, 2026 - 09:31 UTC

Update

We are continuing to investigate this issue.
Posted Feb 02, 2026 - 13:46 UTC

Investigating

We would like to inform you that we are currently experiencing intermittent failures with plan change requests, which are causing delays in processing.

Please be assured that our team is actively investigating the issue and working to resolve it at the earliest to ensure all pending plan changes are completed successfully.

We appreciate your patience and cooperation during this time. Further updates will be shared as progress is made.
Posted Feb 02, 2026 - 13:39 UTC
This incident affected: eSIM Operations (eSIM Server #3 (Main)).