Device Connectivity Issue on Global Roaming Plan

Incident Report for Teal Communications

Resolved

Network performance is now stable across all services, and traffic levels have returned to pre-incident levels. Issue is now resolved
Thanks for your co-operation.
Posted Jul 28, 2025 - 20:41 UTC

Monitoring

A fix has been implemented by our engineering teams in coordination with carrier partners. We are now seeing clear improvements in signalling success rates. We are continuing to monitor the network closely over the next few hours to ensure full stability.
Posted Jul 28, 2025 - 19:12 UTC

Update

Engineering work is ongoing, with further steps taken to ease network congestion. Early signs of improvement are being observed.
Devices may continue to experience intermittent connectivity issues globally, We will provide a further update as soon as additional progress is made. Thank you for your continued cooperation.
Posted Jul 28, 2025 - 18:07 UTC

Update

We're continuing to investigate this issue. Our engineering teams remain engaged with the carrier partners, and work is ongoing to restore normal performance.
Posted Jul 28, 2025 - 15:27 UTC

Identified

We're currently investigating an issue affecting connectivity and data transmission. One of our carrier partners is experiencing increased traffic on part of their network infrastructure (Limited to Global Roaming Plan), which is contributing to degraded performance.

Our engineering teams are working closely with the carrier to resolve the issue as quickly as possible.

We'll provide a further update soon.
Posted Jul 28, 2025 - 13:21 UTC
This incident affected: Network Connectivity.