Voice & Data Service Degradation Across 2G, 3G, and 4G Networks (AVT Plan)

Incident Report for Teal Communications

Resolved

This incident has been resolved.
Posted Apr 07, 2026 - 10:00 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 07, 2026 - 06:50 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 07, 2026 - 06:39 UTC

Investigating

We would like to inform that, one of our upstream provider has detected a degradation in data services (2G,3G,4G) services under the AVT Plan. Our provider is actively engaged in troubleshooting efforts to address and resolve the issue. We apologize for any inconvenience this may cause and appreciate your understanding as they work to restore service. Thank you for your cooperation and patience!
Posted Apr 07, 2026 - 00:19 UTC
This incident affected: Network Connectivity.