Canada - Rogers Native plan - Data Connectivity Issue in Ontario

Incident Report for Teal Communications

Resolved

This incident has been resolved.
Posted Jun 01, 2026 - 18:29 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 01, 2026 - 18:29 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Jun 01, 2026 - 13:52 UTC

Investigating

An incident has been reported with one of our carrier partners impacting attachment and authentication for data services.
Wireless customers in Ontario may experience intermittent service disruptions due to multiple site outages caused by severe weather–related commercial power failures.
Impact: 3G, LTE, 5G services in Ontario
Our technical teams are actively working with the connectivity partner to restore service.
Posted May 31, 2026 - 18:22 UTC
This incident affected: eSIM Operations (eSIM Server #3 (Main)).