Connection Issues on Three Network Profiles

Incident Report for Teal Communications

Resolved

This incident has been resolved.
Posted Mar 27, 2026 - 20:04 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 27, 2026 - 20:03 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 27, 2026 - 20:02 UTC

Investigating

We are observing eSIM registration delays only on Three Network profiles, SIMs may not be able to attach to the network temporarily,
Please wait and try again in 5-10 minutes.
We apologize for the interruption and appreciate your patience while we work to resolve this issue.
Posted Mar 27, 2026 - 16:24 UTC