Service Degradation Notice: 2G/3G Data Connectivity Issues Affecting AVT Profile Cards

Incident Report for Teal Communications

Resolved

This incident has been resolved.
Posted Jun 01, 2026 - 19:02 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 01, 2026 - 18:10 UTC

Investigating

We are currently investigating an incident affecting SIM cards provisioned on the AVT profile, where customers may experience intermittent network registration failures.

Our monitoring systems have identified a sudden increase in network traffic, which is impacting connectivity services through one of our carrier partners.
We apologize for any inconvenience this may cause and appreciate your patience while we work to resolve the issue.
Posted Jun 01, 2026 - 18:00 UTC
This incident affected: Integration API.