Connection Issues on Three Network Profiles

Incident Report for Teal Communications

Resolved

Hutchison 3 profiles have been reprovisioned and services to these networks restored.
Posted Mar 25, 2026 - 15:05 UTC

Update

A reprovisioning is currently underway and should be completed shortly. We will provide an update once this is completed and all work has been validated.
Posted Mar 18, 2026 - 22:25 UTC

Identified

The provisioning issue has been identified, and the host operator is in the process of reprovisioning. We apologize for the interruption and appreciate your patience while we work to resolve this issue.

Sincerely,
Teal Communications
Posted Mar 12, 2026 - 21:46 UTC

Investigating

Inventory was not properly provisioned by the host operator for Three network profiles.
Posted Feb 23, 2026 - 21:49 UTC
This incident affected: eSIM Operations (eSIM Server #2 (Legacy 2), eSIM Server #3 (Main)).