Rogers Native Profile installs are currently failing

Incident Report for Teal Communications

Resolved

This incident has been resolved.
Posted Sep 18, 2025 - 11:36 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 17, 2025 - 04:46 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Sep 15, 2025 - 13:53 UTC

Investigating

We are working to identify the root cause and will implement a resolution as quickly as possible. There is currently no ETA but we will update you shortly.
We do understand the frustration this may cause and sincerely apologize for the inconvenience.
Thank you for your cooperation!
Posted Sep 15, 2025 - 05:46 UTC
This incident affected: Customer Portal.